Уязвимости в Dell Wyse ThinOS позволяют перехватить управление над тонким клиентом — yo-robot.ru

Dell Wyse ThinOS CyberMDX

Эксплуатация уязвимостей позволяет удаленному злоумышленнику запустить вредоносный код и получить доступ к произвольным файлам.

Одиннадцать моделей тонких клиентов Dell Wyse содержат критические уязвимости, эксплуатация которых может быть использована удаленным злоумышленником для запуска вредоносного кода и получения доступа к произвольным файлам.

Уязвимости (CVE-2020-29492 и CVE-2020-29491) содержатся в компонентах ThinOS — операционной системы на тонких клиентах Dell Wyse. ThinOS можно управлять удаленно, для чего Dell рекомендует настроить FTP-сервер для загрузки на устройства обновлений (прошивок, пакетов и конфигураций).

Как обнаружили исследователи безопасности из компании CyberMDX доступ по FTP возможен без учетных данных с использованием «анонимного» пользователя. Они также выяснили, что подписанными Dell оказались только прошивка и пакеты, оставляя файлы конфигурации INI уязвимыми к манипуляциям злоумышленника. На FTP-сервере также есть специальный INI-файл, который должен быть доступен для записи для подключающихся клиентов.

«Поскольку учетные данные отсутствуют, практически любой пользователь в сети может получить доступ к FTP-серверу и изменить конфигурацию хранения этого INI-файла для тонких клиентов», — пояснили эксперты.

Когда устройство Dell Wyse подключается к FTP-серверу, оно ищет INI-файл с его конфигурацией и логином пользователя в названии. Имея возможность записи в данный файл, злоумышленник может установить вредоносную версию для управления конфигурацией, полученной конкретным пользователем в сети.

В рамках одного из сценариев злоумышленник может воспользоваться этими уязвимостями — прочитать или изменить параметры в файле конфигурации, которые предоставят ему удаленный контроль над тонким клиентом. Хищение данных и манипулирование результатами DNS также входят в список рисков, которые могут возникнуть в результате использования двух проблем.

Уязвимости затрагивают следующие модели Dell Wyse под управлением версии ThinOS 8.6 и старше:

Эксперты сообщили о своих находках компании, и Dell исправила проблемы в версиях ThinOS 9.x. Однако проблемы в определенных моделях не могут быть исправлены из-за несовместимости устройств с версиями ThinOS 9.x: Wyse 3020, Wyse 3030 LT, Wyse 5010, Wyse 5040 AIO, Wyse 5060 и Wyse 7010.

Источник: securitylab.ru

Вы можете оставить комментарий, или ссылку на Ваш сайт.


Оставить комментарий

Вы должны войти, чтобы иметь возможность оставлять комментарии.